Wrong ELF class: ELFCLASS64

From Resin 3.0

Revision as of 13:42, 2 January 2006 by Sam (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


I compiled Resin for 64-bit:

# ./configure --enable-64bit ...
        

But when I start Resin I get the following error:

[17:59:43.484] java.lang.UnsatisfiedLinkError: /usr/local/share/resin/libexec/libresin.so: ld.so.1: 
/usr/java/bin/java: fatal:  /usr/local/share/resin/libexec/libresin.so: wrong ELF class: ELFCLASS64

Some jvm binaries can function in both 64-bit and 32-bit mode. For those jvm's, pass the -J-d64 argument to httpd when Resin is started.

Personal tools