Package javax.resource.spi has no specification version. Resin XXXX requires version YYYY.

From Resin 3.0

Revision as of 08:17, 7 December 2005 by Sam (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Some software ships with an incorrectly packaged version of the javax.management classes. Resin ships with lib/jca-XX.jar, and that should be the only javax.management implementation in the classpath.

Resin is required to check the versions of the packages it uses. Resin notifies you if there's an old API in your classpath. If another jar in the classpath is missing the version number, that's interpreted as being an obsolete version.

The specific issue with JMX was that Sun changed the package version number for all of its jars to be 1.5 no matter which version of the specification was implemented, so Resin was interpreting several 1.5 packages as obsolete, when it was merely a naming convention change.

Personal tools